Ayuda con codigo

Si eres principiante y tienes alguna consulta entra en este foro.
Responder
Mensaje
Autor
Snapmx
Mensajes: 4
Registrado: 12/08/2019 11:52 am

Ayuda con codigo

#1 Mensaje por Snapmx » 07/09/2019 10:46 am

Buenas tarde necesito de su ayuda tengo para subir este programa que corra bien para mi calificación final en la escuela solo tengo el algoritmo serian de mucha ayuda

/*Empresa*/
Escribir 'Digite la cantidad de empleados'
Leer n
c1=0
c2=0
c3=0
c4=0
c5=0
c6=0
Para c<-1 Hasta n Con paso 1 Hacer
Escribir ''
Escribir ''
Escribir 'digite su sexo'
leer g
si g="Hombre" Entonces
c1=c1+1
Escribir 'Digite su edad'
Leer em
si em>50 Entonces
c3=c3+1
FinSi
Escribir'Digite sueldo'
Leer sm
si em<40 y sm<40000 Entonces
c2=c2+1
FinSi
Sino g="mujer"
c4=c4+1
Escribir 'digite su edad'
Leer ef
Si ef>50 Entonces
c5=c5+1
FinSi
Escribir 'digite su sueldo'
leer sf
Si sf>20000 Entonces
c6=c6+1
FinSi
s=c3+c5
FinSi
escribir ' '
FinPara
Escribir 'total de nombres:', c1
Escribir 'total de mujeres:', c4
Escribir 'total de mujeres que ganan mas de 20000:', c6
Escribir 'total de hombres menores de 40años que ganan menos de 40000:', c2
Escribir 'total de empleados mayores de 50 años:', s
FinProceso

nxbl07
Mensajes: 1
Registrado: 08/09/2019 9:52 am

Re: Ayuda con codigo

#2 Mensaje por nxbl07 » 08/09/2019 10:04 am

Hola,
Antes de responder me podrías decir que significa FinSi porfi?

dehm
Mensajes: 304
Registrado: 29/04/2011 7:31 am

Re: Ayuda con codigo

#3 Mensaje por dehm » 08/09/2019 11:29 pm

nxbl07 escribió:
08/09/2019 10:04 am
Hola,
Antes de responder me podrías decir que significa FinSi porfi?
Hola. Yo entiendo a que se refiere al final de un bloque if. Por ejemplo esto:
Leer sm
si em<40 y sm<40000 Entonces
c2=c2+1
FinSi
se "traduciría" en

Código: Seleccionar todo

cin>>sm;
if (em<40 && sm<40000)
{
    c2=c2+1;
}
Aprendiendo

Responder

¿Quién está conectado?

Usuarios navegando por este Foro: Bing [Bot], Google [Bot] y 8 invitados